Wednesday, November 25, 2009

Not again!!!!

Yesterday my CGM sensor started to bother me a little bit.  Considering what happened last time you would I think would have pulled it out right away.  I didn't.  But when it was so sore that it woke me up at 2 am, I took it right out.  Squinting as the bathroom light attacked my sleepy eyes, I saw this.

That's right, another welt. Not only did I see it, but I could feel it too.  Quite a lump was left behind where the sensor came out.  This picture was actually taken 12 hours after I took the sensor out.  It doesn't hurt any more, but it still looks bad.

 I have no idea what is going on with these sensors.  I've always been able to wear them for 6 to 8 days without a problem.  But these last two haven't even lasted four days.  Has Minimed changed how they make them?  Is there something new in them that my body can't seem to tolerate?  I plan to call and find out.  But I'd love to know if any other Minimed CGM wearers have been suddenly having problems too.  If you wear one, please comment and let me know if they are working fine for you or not.  I'm starting to get aggravated, but with the nasty low I had on Sunday I really don't want to go without my CGM.


  1. Karen-

    Ouch! That looks painful. I wish I had an answer for you:) I hope everything gets figured out.

  2. Um, I hate to break it to you, but the sensors kind of suck. But you knew that. Hang in there.

    Happy Turkey Day!
    - AmyT

  3. Yep. I only get welts when I leave them in for 6 days. If I take them out at day 3, there isn't anything wrong. I think my body just hates having things in my skin for a long time. I have the same problem with my sets lately. I used to be able to leave them in for 4-5 days without an issue. Now I can't go past 3 days without getting the uglies.

    But as far as how accurate the sensors are, I think they are great. :-)

  4. I've wondered if something has changed recently myself. I've had several terribly itchy/painful sensors from the latest box as well, and the adhesive doesn't seem to be sticking worth a crap. I don't know if it's just a coincidence or if they actually changed the manufacturing process. Or maybe like Amy said, the sensors just suck.


Thanks for your comment!